Skip to content

I am receiving an error TLSV1_ALERT_PROTOCOL_VERSION when starting docker-compose

You have to tell Docker-Compose to use a higher TLS version by setting an environment variable COMPOSE_TLS_VERSION (see here for details)

$ docker-compose up -d
SSL error: [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:661)
$ export COMPOSE_TLS_VERSION=TLSv1_2
$ docker-compose up -d
Creating network "premium_default" with the default driver
...